node-weixin-api v 0.5.0发布

Author Avatar calidion 发表于 • 2016年04月21日 21:38 • 共 • 1160 • 次浏览

由于npm3虽然引入了flat模式,但是仍无法解决不同版本的包的flat问题。 所以由于npm3的node-weixin-settings出现在不同版本时无法达包共享。 所以这次变更的原因也是基于解决npm3下setting也无法共享的问题所做出的重新调整。

将所有使用到settings的项目的全部重写,将settings作为参数传入。 调整了参数的传入次序: settings -> app -> 其它参数 涉及变更的包有: node-weixin-auth ^0.5.0 → ^0.6.0 node-weixin-jssdk ^0.4.0 → ^0.5.0 node-weixin-link ^0.4.0 → ^0.5.0 node-weixin-media ^0.4.1 → ^0.5.0 node-weixin-menu ^0.5.0 → ^0.6.0 node-weixin-message ^0.0.10 → ^0.1.0 node-weixin-user ^0.5.0 → ^0.6.0

源码:https://github.com/node-weixin/node-weixin-api

最后编辑于 • 2016年10月25日 23:52 •  
1 回复
avatar
0
发放红包 2016年04月22日 06:16   # 1 楼

这个必须赞一下。不过暂时还不能升级,待时间宽松点再升级版本

你尚未登录,无法进行回复。